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Quick Start Guide
1. Preface

The purpose of this document is to help you get started using HIPE with the minimum of fuss, confu-
sion, time wasted, and Helpdesk (please open this link in a new tab or window) tickets raised.

This document assumes the following:

• You have installed HIPE without any issues.

• You have registered with the Herschel system. Go to Herschel registration page (please open this
link in a new tab or window) if not.

• You have an account with permission to access the Herschel Science Archive (HSA).

• You know the observation ID for at least one set of data.

By the end of this document you will have achieved the following:

• Transferred one observation for inspection from the HSA into your HIPE session.

• Developed a broad understanding of the data structure that you see.

• Learnt how to look at your data.

• Begun to have an understanding of where you can go from here, and where in the documentation
to look next.

The first step after checking both lists (especially the first one) is to launch the main program of HIPE.
Being a cross-platform application, instructions for the major operating systems follow:

• Linux and UNIX: You will find links to the executable file according to the choices made during
installation. The options are: the home directory (default), a specific directory and no links (you
will have to execute the application directly from the installation directory). If you are running the
program from the terminal you should type hipe or ./hipe depending on the shell.

• Mac OS X: After installation, you will find HIPE on the Desktop. It is also available searching for
hipe in Spotlight and at the installation directory.

• Windows: After installation, you will find HIPE on the Start Menu (or Start Screen in Windows 8),
on the Desktop (if you decided to create shortcuts there) or directly at the installation directory.

In any of the previous cases, when you locate the link or executable file double click it to run the
program.

Clicking in HIPE

Click behaviour within HIPE is very similar to any other GUI-based application:
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• One click for selection/highlighting.

• Double click for expanding a tree (for example, the Navigator view or the Tasks view)
or accessing a detail view (a data viewer when double-clicking a product in the Obser-
vations list).

You will not have transferred data onto your hard disk. To learn how to do this see the Data Analysis
Guide: Section 1.2 in Data Analysis Guide.

This document is intended to be read as you carry out these actions in HIPE. It does not describe any
of the other views you see in the main HIPE window. For that, please see the HIPE Owner's Guide.

2. Access the Herschel Science Archive
To easily access data stored in the archive, you must first ensure that, within HIPE, you are logged in
the Herschel Science Archive (HSA). Typically this must be done only once.

Check your login status by inspecting the HIPE status bar at the bottom. If you are not logged in,
the text "HSA Log-in" will be visible as shown in Figure 1. Double-click on this part of the status
bar and enter your Herschel username and password. Tick the Remember checkbox if you want HIPE
to store your credentials securely--then you won't have to re-enter your login and password in future
HIPE sessions.

Note

Please note that if you ever change or reset the password of the HSA account and you
chose the option to remember the credentials, those old credentials will still be stored in
your system. Therefore HIPE will consider your account as logged in, and this could then
can result in permission errors when querying the HSA. In this case, you should explicitly
log out by double-clicking your username in the bottom status bar. After this, you can
double-click again to log in again, using the current password, or you can wait until HIPE
prompts you to log in.

Figure 1. Logging in to the Herschel Science Archive

Once you have logged into the archive, you can move to the Welcome page (see below).
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Figure 2. Accessing the Herschel Science Archive

Starting on the Welcome page (the default view on first opening HIPE), click on Data Access. In the
Access to Herschel Data view that appears, click Data Access again (see Figure 2). This launches
the Data Access perspective, a comprehensive set of components to handle data downloaded from
the Archive. Among these components you will find the Herschel Science Archive view. Clicking on
Open HSA User Interface will launch the archive interface.

Tip

If you cannot see the Welcome page, click the  icon at the top right corner of the HIPE

main window. Also, in the same toolbar to the left, you can always find an icon  that
instantly launches the HSA interface.
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Figure 3. The HSA view

In the Herschel Science Archive view, click Open HSA User Interface to launch the HSA application.
You may need to accept the security certificate (see Figure 3).

Tip

If you cannot find the Open HSA User Interface button in the HIPE window, go to the
top-level menu item Window → Show View → Data Access → Herschel Science Archive.
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3. Query the HSA

Figure 4. Querying the HSA (search)

Figure 5. Querying the HSA (results)

These steps are performed in the HSA web application, which is not part of HIPE but communicates
with it (see above).

Tip

If you encounter problems with the HSA web application, or in any other point of the
procedure using the graphical interface, you can also retrieve an observation via the com-
mand line. See the end of Section 4 for more details.

Enter a valid observation ID in the Observation id field. To access this field, you need to expand the
Observation constraints section by clicking on its title. Click on the Search button: you should obtain
one result in a new screen (switching screens is done via the left menu bar). Click the download icon
in the result line, then choose All from the Download Products dialogue.

Since any observation ID is unique, it is all you need to know to find your data. You can also do more
involved queries, for instance per instrument and/or observing mode.

5



Quick Start Guide Build 15.0.3262

4. Get the data into HIPE

Figure 6. Loading data into HIPE

Back in HIPE, data are automatically imported and appear as a new variable in the Variables view
(see Figure 6). The variable name contains the ID of your observation. Click on the variable to see an
outline of the observation in the Outline view.

Tip

If you cannot see the Variables or Outline views, open them via the Window → Show View
→ Workbench menu.

Note that the views could be in a different position than shown in Figure 6. To restore all

the views to their default positions, click the  icon at the top right corner of the HIPE
main window, and click Yes in the dialogue window that appears.

You can also retrieve the data via the command line. To do so, follow these steps:

1. Make sure you are logged into the Herschel Science Archive. See Section 2 for details.

2. Issue the following command in the Console view of HIPE:

myObsid = 1342180473

You can use any variable name instead of myObsid. Replace 1342180473 with the actual ID of
your observation. If you cannot see the Console view, open it by choosing Window → Show View
→ Workbench → Console.

3. Issue the following command in the Console view of HIPE:

myObs = getObservation(obsid=myObsid, useHsa=True)

A new variable myObs appears in the Variables view. This is a reference to your observation, just
like you would obtain by using the HSA application.

The method described above is ideal for inspecting data quickly, but does not store data on your ma-
chine. The recommended way to download and save data from the HSA is to use the getObserva-
tion task with the save=True parameter, or to download a tar file from the HSA and then use the
getObservation task to load it into HIPE. See the Data Analysis Guide for details: Section 1.2
in Data Analysis Guide.
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5. Inspect your data

Figure 7. Inspecting an observation

You can navigate through and inspect the contents of your observation using the Observation Viewer .

To look at your Level 2 data, click on the Level 2 product in the lower left area of the Observation
Viewer. The Level 2 product contains other products, which can themselves contain other products.
This onion skin arrangement of products is represented in the Observation Viewer by a hierarchical
structure. The data you want are right in the middle of the onion, so click on through until you reach
the bottom product. Inside that you will find your data.

Figure 8. Opening an image with the Standard Image Viewer
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Typically, double clicking on a product opens the data in the most appropriate tool with which to view
them. You can also right click and choose a specific viewer from the Open With menu. The following
are the two viewers you are likely to use most often:

• Spectrum Explorer in Data Analysis Guide, for single point spectra and spectral cubes (all instru-
ments).

• Standard Image Viewer in Data Analysis Guide, for PACS and SPIRE photometry.

What is an Observation Context?

All Herschel observations are packaged as Observation Contexts. An Observation Context
contains all the meta data and data products associated with an observation. In other words,
it is the box we give you your data in.

The structure of an Observation Context is the same for all instruments and observing
modes. As you can see in Figure 7, an Observation Context contains the following prod-
ucts:

          

History: Contains the automatically generated script of ac-
tions performed on your data, a history of the tasks
applied to the data, and the parameters belonging
to those tasks.

Auxiliary context: All Herschel non-science spacecraft data required
directly or indirectly in the processing and analysis
of the scientific data.

Browse image product A thumbnail image associated with an observation.
This is the thumbnail you see when you browse
observations in the Herschel Science Archive, or
when you open an observation with the Observa-
tion Viewer in HIPE.

Browse product A representative product from an observation, for
example an image or a spectrum. Useful for quick
browsing and inspection of observations.

Calibration context: The parameters that characterise the behaviour of
the satellite and the instruments. Used for repro-
cessing data.

Level-0 context: Raw data, minimally manipulated.

Level-0.5 context: Data processed to an intermediate point adequate
for inspection.

Level-1 context: Detector readouts calibrated and converted to
physical units, in principle instrument and obser-
vatory independent.

Level-2 context: Scientific analysis can be performed. These data
products are in theory at a publishable quality lev-
el and should be suitable for Virtual Observatory
access. However, please consult the TWiki pages
set up by HIFI, PACS and SPIRE for more infor-
mation on the quality of these products.

Level-2.5 context: • For PACS, level 2.5 products are photo-
metric maps (SimpleImage) produced with
MadMap and the high-pass-filter pipeline, com-
bining the scan and cross-scan AORs.
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• For SPIRE, level 2.5 products are destriped
maps combinining from the scan and cross-scan
AORs from parallel mode.

• For HIFI, level 2.5 contents depend on the AOT.
Broadly there are three kinds of HIFI AOTs:
single point observations, spectral scan observa-
tions and mapping observations. The first two
of these will produce one or more single spectra
while the last will produce a spectral cube.

Level-3 context: • For the PACS photometer, level 3 products are
photometric maps (SimpleImage) produced
by the high-pass-filter pipeline, combining all
overlapping images from a given program.

• For the SPIRE photometer, level 3 products are
combined maps of any overlapping areas from
the same proposal using scan mode AOTs. The
maps are mosaics of the level-2 maps that have
been calibrated for extended emission and have
the Planck zero-level correction applied.

Observation log context: A log of actions performed on the Products in the
observation context.

Quality context: Issues flagged by the pipelines that indicate possi-
ble issues with the quality of the data or pipelining.
An empty quality report indicates no problems in
processing.

Trend analysis context Products useful for tracking systematic changes in
instrument response over time.

6. Moving into data analysis and reprocess-
ing

6.1. Starting data analysis
Now that you have had a first look at your data, you will probably want to do so a little more quanti-
tatively by, for example, fitting spectral features in Data Analysis Guide, or comparing with data from
other observatories by importing non-Herschel FITS files in Data Analysis Guide. You may wish to
do some basic photometry in Data Analysis Guide or other image analysis in Data Analysis Guide
among other things, for all of which you should look in the Data Analysis Guide.

6.2. Reprocessing data
After looking at your data, you may decide that you are not happy with how they were reduced.
Because you are supplied with raw data and all calibration and auxiliary products, you can reprocess
the data yourself. The information you need to reprocess data can be found in the separate instrument
data reduction guides:

• HIFI Data Reduction Guide

• PACS Data Reduction Guide for photometry and spectroscopy

• SPIRE Data Reduction Guide
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